An uploaded image appearing cut off at the bottom, in Play mode

Use this template to make awesome bug reports:

Your username: t1

What kind of device are you using?: iPad Pro (10.5-inch), iOS 14.1 (18A8395)

Hopscotch version is in TestFlight beta 3.44.3 (1)

1 sentence description of the problem (I was doing _________, and then __________ happened):

I uploaded a large image into the editor. It appeared whole in the editor. When I went into Play mode, the image became cut off at the bottom.

Steps that the Hopscotch team can take to reproduce my problem every time:

  1. Upload this image into the editor https://www.dropbox.com/s/dcztkzkncxkv4li/Oven-Sketch.png?dl=0
  2. Press Play
    ….

I expected this to happen:

The image would remain whole

But instead this happened:

The image became cut off at the bottom

Here’s a sweet screenshot:

In the editor:

In Play mode:

14 Likes

Yeah like I said, I had an issue like this once before. It was with a project I was unable to complete due to app bugs :(

I searched up clip arts of backpacks and a couple of them had issues like cutting the left or right half of the image entirely. Finally found one that didn’t do that so it might be the file of the image?

9 Likes

Oh that gave me an idea - I made the image in Procreate so I just decided to try make it much smaller. It behaves as expected now:

In the editor:

In play mode:

6 Likes

Hm. Not the first time the resolution size of an image affected a project or the editor like that

I wonder if THT can fix this or if it’s capped like that for a reason. However, if it’s capped for a reason, I think you should get an alert saying that the image size is too large

7 Likes

I don’t have any experience with custom art, so these suggestions might not work but try them anyway:

1. Exit the app (and swipe out your window)
2. If that doesn’t work restart your device
3. If that still doesn’t work, try starting a new project and downloading the image there
4. Try making the image smaller


Most likely, none of my solutions will work as I have never used custom art. But I hope this bug gets fixed soon! Have an amazing day/night!

2 Likes

Hmm weird
Maybe hs set the wrong width/height for the image?

1 Like

For serenity’s Pokemon thingy the pic of Infernape was cut out

2 Likes

Yeah with large images, sometimes saving the image several times thru different places works.

3 Likes

This has happened to me before ;-; had to change the images a little bit

2 Likes

This happened to me as well.

2 Likes

This has happened to me with some emojis too

1 Like

It happened to me with text as well

2 Likes

I hate it when that happens.

1 Like

that is a very good drawing!!! :smile:

2 Likes

Pls go on topic.

1 Like