0.4 second turns to 1 second (Open)

Use this template to make awesome bug reports:

Your username: Dakoan

What kind of device are you using?: iPad Air 2

1 sentence description of the problem (I was doing _________, and then __________ happened): I was doing a wait 0.4 second block and then i tapped the up arrow button and then that happened

Steps that the Hopscotch team can take to reproduce my problem every time:

  1. Create a Wait Seconds block with 0.4
  2. Tap the up arrow button

I expected this to happen:
The wait second block to be 0.5
But instead this happened:
It turned into 1 second
Here’s a sweet screenshot:


9 Likes

I don’t think this is a bug, just not a feature THT included.

It would be cool if the up button didn’t always go up by 1, and could go up by 0.1 or 0.01 depending on how many decimal places there were.

9 Likes

The changing by more than .1 is not a bug, the changing by less than 1 is.


9 Likes

Actually, a real bug with this is that for example 347.2 turns into 1 when the up arrow is pressed.

6 Likes

A post was merged into an existing topic: The number arrows should change numbers with decimals by .1 (Open)

We are currently cleaning up the bugs category and Petrichor only linked a topic about this, so I merged your post there.

Whether this is a bug or just a “missing feature” can also be considered.

This turned out to be a bug - I misunderstood and apologize. The topic is now reopened again and the title marked with “Open” to indicate that this bug has not been solved.

@William04GamerA you’re good

3 Likes

Use this template to make awesome bug reports:

Your username: Dakoan

What kind of device are you using?: iPad Air 2

1 sentence description of the problem (I was doing _________, and then __________ happened): I was doing a wait 0.4 second block and then i tapped the up arrow button and then that happened

Steps that the Hopscotch team can take to reproduce my problem every time:

  1. Create a Wait Seconds block with 0.4
  2. Tap the up arrow button

I expected this to happen:
The wait second block to be 0.5
But instead this happened:
It turned into 1 second
Here’s a sweet screenshot:


8 Likes

@William04GamerA There was a bug. Look at my post, it should have changed to 1.4, not 1.

6 Likes

Yeah, but I thought this topic was related to the issue. It was a bit confusing though - so Daokan’s thing is an individual bug and should be moved back into a separate topic?

4 Likes

I think so; I was confused a little by the move as well

3 Likes

I can’t replicate it

4 Likes

Sorry, I’ll see what I can do to move it back.

3 Likes

We’re back.

2 Likes

this conversation is confusing me

2 Likes

Thanks so much for reporting this @Dakoan! I’m trying to replicate it on my devices but haven’t been able to so far. If you notice any conditions where the issue seems to not occur for you (for example, if you place your ‘Wait’ block within a different rule type and it appears to resolve the issue) please let me know - this could help us figure out the root cause.

Has anyone else been able to reproduce the issue? If so, could you please share the device type you were using and a screen shot of your code if available? Thanks all!

6 Likes

Hmmmm i think i know why i got this bug…


Yeah i think my iPad version is old I haven’t updated it because i’m lazy

6 Likes